M9210A User Manual

You are here: M9210A User Manual

Agilent Technologies

M9210A PXI-H 10-bit Digitizing Scope

User Manual

Introduction

This help document is intended to provide in-depth information and reference material specific to your digitizer product.

For information on getting started with your digitizer, please refer to the StartUp Guide which was delivered with your product or may be downloaded from the Agilent Technologies website.

Contents:

Notices & General Information

Description & Front Panel Connections

Channel Input

Data Acquisition

Trigger

External Clock & Reference

Calibration

Trigger Output

Multi-Purpose Inputs and Outputs

Electrical, Environmental & Physical Specifications

AS Bus 2 Operation

Utilities

Accessories

© Agilent Technologies, Inc. 2013. | Help version: 02 December 2013
Part No: M9210-90005 |


Notices

© Agilent Technologies, Inc. 2013

No part of this manual may be reproduced in any form or by any means (including electronic storage and retrieval or translation into a foreign language) without prior agreement and written consent from Agilent Technologies, Inc. as governed by United States and international copyright laws.

Manual Part Number

M9210-90005

Support

To contact Agilent for sales and technical support, refer to the “support” links on the following Agilent web resources:

www.agilent.com/find/Digitizers - Home page for the entire range of Agilent modular digitizer products.

www.agilent.com/find/assist - Worldwide contact information for repair and service.

www.agilent.com/find/tips - Information on preventing damage to your Agilent equipment.

Regulatory Compliance

This product has been designed and tested in accordance with accepted industry standards, and has been supplied in a safe condition. To review the Declaration of Conformity, go to http:/regulations.corporate.agilent.com/DoC/search.htm.

Warranty

The material contained in this document is provided “as is,” and is subject to being changed, without notice, in future editions. Further, to the maximum extent permitted by applicable law, Agilent disclaims all warranties, either express or implied, with regard to this manual and any information contained herein, including but not limited to the implied warranties of merchantability and fitness for a particular purpose. Agilent shall not be liable for errors or for incidental or consequential damages in connection with the furnishing, use, or performance of this document or of any information

contained herein. Should Agilent and the user have a separate written agreement with warranty terms covering the material in this document that conflict with these terms, the warranty terms in the separate agreement shall control.

Technology Licenses

The hardware and/or software described in this document are furnished under a license and may be used or copied only in accordance with the terms of such license.

Restricted Rights Legend

If software is for use in the performance of a U.S. Government prime contract or subcontract, Software is delivered and licensed as “Commercial computer software” as defined in DFAR 252.227-7014 (June 1995), or as a “commercial item” as defined in FAR 2.101(a) or as “Restricted computer software” as defined in FAR 52.227-19 (June 1987) or any equivalent agency regulation or contract clause. Use, duplication or disclosure of Software is subject to Agilent Technologies’ standard commercial license terms, and non-DOD Departments and Agencies of the U.S. Government will receive no greater than Restricted Rights as defined in FAR 52.227-19(c)(1-2) (June 1987). U.S. Government users will receive no greater than Limited Rights as defined in FAR 52.227-14 (June 1987) or DFAR 252.227-7015 (b)(2) (November 1995), as applicable in any technical data.

Conventions Used in this Document

The following convetions are used in this document:

A WARNING notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in personal injury or death. Do not proceed beyond a WARNING notice until the indicated conditions are fully understood and met.

A Caution notice denotes a hazard. It calls attention to an operating procedure, practice, or the like that, if not correctly performed or adhered to, could result in damage to the product or loss of important data. Do not proceed beyond a CAUTION notice until the indicated conditions are fully understood and met

This is a note, drawing the reader's attention to important information, caveats, etc.

'Italic' text denotes a reference to a quoted name or entity. e.g."Press the 'Run' button."

Bold Italic text is used to emphasize an important action point in the text. e.g. "Open the View menu and select the All option."

mono text is used for sections of code, programming examples and operating system commands. e.g. "Type the command >> Run -all"

Underlined Italic text denotes paths or file names. e.g. "The file is located in the folder, e.g...\Agilent\MD1\.."

Safety Notices

The following safety precautions should be observed before using this product and any associated instrumentation.

This product is intended for use by qualified personnel who recognize shock hazards and are familiar with the safety precautions required to avoid possible injury. Read and follow all installation, operation, and maintenance information carefully before using the product.

If this product is not used as specified, the protection provided by the equipment could be impaired. This product must be used in a normal condition (in which all means for protection are intact) only.

The types of product users are:

  • Responsible body is the individual or group responsible for the use and maintenance of equipment, for ensuring that the equipment is operated within its specifications and operating limits, and for ensuring operators are adequately trained.
  • Operators use the product for its intended function. They must be trained in electrical safety procedures and proper use of the instrument. They must be protected from electric shock and contact with hazardous live circuits.
  • Maintenance personnel perform routine procedures on the product to keep it operating properly (for example, setting the line voltage or replacing consumable materials). Maintenance procedures are described in the user documentation. The procedures explicitly state if the operator may perform them. Otherwise, they should be performed only by service personnel.
  • Service personnel are trained to work on live circuits, perform safe installations, and repair products. Only properly trained service personnel may perform installation and service procedures.

Agilent products are designed for use with electrical signals that are rated Measurement Category I and Measurement Category II, as described in the International Electrotechnical Commission (IEC) Standard IEC 60664. Most measurement, control, and data I/O signals are Measurement Category I and must not be directly connected to mains voltage or to voltage sources with high transient over-voltages. Measurement Category II connections require protection for high transient over-voltages often associated with local AC mains connections. Assume all measurement, control, and data I/O connections are for connection to Category I sources unless otherwise marked or described in the user documentation.

Exercise extreme caution when a shock hazard is present. Lethal voltage may be present on cable connector jacks or test fixtures. The American National Standards Institute (ANSI) states that a shock hazard exists when voltage levels greater than 30 VRMS, 42.4 V peak, or 60 VDC are present. A good safety practice is to expect that hazardous voltage is present in any unknown circuit before measuring.

Operators of this product must be protected from electric shock at all times. The responsible body must ensure that operators are prevented access and/or insulated from every connection point. In some cases, connections must be exposed to potential human contact. Product operators in these circumstances must be trained to protect themselves from the risk of electric shock. If the circuit is capable of operating at or above 1000 V, no conductive part of the circuit may be exposed.

Do not connect switching cards directly to unlimited power circuits. They are intended to be used with impedance-limited sources. NEVER connect switching cards directly to AC mains. When connecting sources to switching cards, install protective devices to limit fault current and voltage to the card.

Before operating an instrument, ensure that the line cord is connected to a properly-grounded power receptacle. Inspect the connecting cables, test leads, and jumpers for possible wear, cracks, or breaks before each use.

When installing equipment where access to the main power cord is restricted, such as rack mounting, a separate main input power disconnect device must be provided in close proximity to the equipment and within easy reach of the operator.

For maximum safety, do not touch the product, test cables, or any other instruments while power is applied to the circuit under test. ALWAYS remove power from the entire test system and discharge any capacitors before: connecting or disconnecting cables or jumpers, installing or removing switching cards, or making internal changes, such as installing or removing jumpers.

Do not touch any object that could provide a current path to the common side of the circuit under test or power line (earth) ground. Always make measurements with dry hands while standing on a dry, insulated surface capable of withstanding the voltage being measured.

The instrument and accessories must be used in accordance with its specifications and operating instructions, or the safety of the equipment may be impaired.

Do not exceed the maximum signal levels of the instruments and accessories, as defined in the specifications and operating information, and as shown on the instrument or test fixture panels, or switching card.

When fuses are used in a product, replace with the same type and rating for continued protection against fire hazard.

Chassis connections must only be used as shield connections for measuring circuits, NOT as safety earth ground connections.

If you are using a test fixture, keep the lid closed while power is applied to the device under test. Safe operation requires the use of a lid interlock.

Instrumentation and accessories shall not be connected to humans.

Before performing any maintenance, disconnect the line cord and all test cables.

To maintain protection from electric shock and fire, replacement components in mains circuits – including the power transformer, test leads, and input jacks – must be purchased from Agilent. Standard fuses with applicable national safety approvals may be used if the rating and type are the same. Other components that are not safety-related may be purchased from other suppliers as long as they are equivalent to the original component (note that selected parts should be purchased only through Agilent to maintain accuracy and functionality of the product). If you are unsure about the applicability of a replacement component, call an Agilent office for information.

No operator serviceable parts inside. Refer servicing to qualified personnel. To prevent electrical shock do not remove covers. For continued protection against fire hazard, replace fuse with same type and rating.

Front and Rear Panel Symbols:

The CE mark is a registered trademark of the European Community.

The C-Tick mark is a registered trademark of the Australian Spectrum Management Agency.

This symbol indicates product compliance with the Canadian Interference-Causing Equipment Standard (ICES-001). It also identifies the product is an Industrial Scientific and Medical Group 1 Class A product (CISPR 11, Clause 4).

South Korean Class A EMC Declaration. this equipment is Class A suitable for professional use and is for use in electromagnetic environments outside of the home.

A 급 기기 ( 업무용 방송통신기자재 ) 이 기기는 업무용 (A 급 ) 전자파적합기기로서 판 매자 또는 사용자는 이 점을 주 의하시기 바라 며 , 가정외의 지역에서 사용하는 것을 목적으 로 합니다 .

This symbol indicates separate collection for electrical and electronic equipment, mandated under EU law as of August 13, 2005. All electric and electronic equipment are required to be separated from normal waste for disposal (Reference WEEE Directive, 2002/96/EC).

This symbol on an instrument means caution, risk of danger. You should refer to the operating instructions located in the user documentation in all cases where the symbol is marked on the instrument.

This symbol indicates the time period during which no hazardous or toxic substance elements are expected to leak or deteriorate during normal use. Forty years is the expected useful life of the product.

ESD Sensitive Device

This symbol indicates the instrument is sensitive to electrostatic discharge (ESD). ESD can damage the highly sensitive components in your instrument. ESD damage is most likely to occur as the module is being installed or when cables are connected or disconnected. Protect the circuits from ESD damage by wearing a grounding strap that provides a high resistance path to ground. Alternatively, ground yourself to discharge any built-up static charge by touching the outer shell of any grounded instrument chassis before touching the port connectors.

This symbol denotes a hot surface. The side cover of the module will be hot after use and should be allowed to cool for several minutes.

Cleaning Precautions:

To prevent electrical shock, disconnect the Agilent Technologies instrument from mains before cleaning. Use a dry cloth or one slightly dampened with water to clean the external case parts. Do not attempt to clean internally. To clean the connectors, use alcohol in a well-ventilated area. Allow all residual alcohol moisture to evaporate, and the fumes to dissipate prior to energizing the instrument.

Definitions for specifications

Specifications describe the warranted performance of calibrated instruments that have been stored for a minimum of 2 hours within the operating temperature range of 0 to 45 °C, unless otherwise stated, and after a 45 minute warm-up period. Data represented in this document are not specifications unless otherwise noted.

Characteristics describe product performance that is useful in the application of the product, but that is not covered by the product warranty. Characteristics are often referred to as Typical or Nominal values.

  • Typical describes characteristic performance, which 80% of instruments will meet when operated over a 20 to 30 °C temperature range. Typical performance is not warranted.
  • Nominal describes representative performance that is useful in the application of the product when operated over a 20 to 30 °C temperature range. Nominal performance is not warranted.


TIP: Help Search Techniques

You are here: M9210A User Manual > Notices & General Information > TIP: Help Search Techniques

TIP: Help Search Tricks

In the help system, a basic search of topics consists of the word or phrase that you want to find. You can, however, improve your search results by using wildcard expressions, nested expressions, Boolean operators, and searching similar word matches, previous results, and topic titles only.

Performing a Basic Full-Text Search

  1. In the navigation pane, click the Search tab and then type the word or phrase that you want to find. Use the right-arrow button to add Boolean operators to your search.
  • Click List Topics.Your search will return the first 500 hits. If you want to sort the topic list, click Title, Location, or Rank.
  • Highlight the topic that you want, and then click Display You can also display any topic by double-clicking it.

Refining a Your Search

You can refine a basic search by using wildcard expressions, nested expressions, and Boolean operators. You can also search only on the previous results list, request similar word matches, or search only the titles of topics in the table of contents.

  • To refine a search to include just the last group of topics you searched, select the Search previous results check box.
  • To match similar spellings in a full-text search, select the Match similar words check box.

When Match similar words is selected, the viewer matches minor grammatical variations of the word or phrase you entered, as well as the word or phrase itself. For example, if you entered "test" and selected this box, the Library viewer would find "test", "tests", and "testing". This option is independent of other options or syntax. If you do a titles-only search, variations in titles will be matched. If you use quotes (or any other query operator) any variation of the word can appear; for example, "installed module" will also match "installing module".

  • To search for words in document titles only, select the Search titles only check box.

Search Syntax

The basic rules for formulating queries are as follows:

  • Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.
  • You can search for any combination of letters (a–z) and numbers (0–9). You cannot search for single letters (a, b, c, etc.) and the following reserved words: an, and, as, at, be, but, by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, with, you.
  • Punctuation marks such as the period (.), colon (:), semicolon (;), comma (,), and hyphen (-) are ignored during a search.
  • Group the elements of your search using "double quotes" or (parentheses). You cannot search for quotation marks.

If you are searching for a filename with an extension, you should group the entire string in double quotes ("filename.ext"). Otherwise, the search will treat the period as an OR operator.

Words, Phrases, and Wildcards

You can search for words or phrases and use wildcard expressions. The table below describes the results of these different kinds of searches.

Search for | Example | Results
Single word | Calibrate | Topics that contain the word "calibrate." (You will also find its grammatical variations, such as "calibration" and"calibrated".)
Phrase | "saved configuration" -or- 'saved configuration' | Topics that contain the literal phrase "saved configuration" and all its grammatical variations. Without the quotation marks, the query is equivalent to specifying a saved AND configuration, which will find topics containing both of the individual words, instead of the phrase.
Wildcard expressions | Meas* | Topics that contain the terms "Meas," "measure," "measurement," and so on. The asterisk cannot be the only character in the words.
 | 89?00 | Topics that contain the terms "89500," "89600," "89700," and so on. The question mark cannot be the only character in the term.
 | *936* | Topics that contain the terms "936." "45936,""M9360A," "93600" and so on.
 | *93 | Topics that contain the terms "293," "393," "x93," "ABCD393," "8093," and so on.

Operators: AND, OR, NOT, and NEAR

The AND, OR, NOT, and NEAR operators allow you to refine your search. The following table shows how to use each of these operators.

Search for | Example | Results
Both terms in the same topic | performance AND verification -or- performance & verification | Topics containing both the words "performance" and "verification."
Either term in a topic | front OR panel -or- front | panel | Topics containing either the word "front" or the word "panel."
The first term without the second term | system NOT requirements -or_ system ! requirements | Topics containing the word "system," but not the word "requirements."
Both terms in the same topic, close together | install NEAR hardware | Topics containing the word "install" within eight words of the word "hardware."

Rules for Nested Expressions

The basic rules for searching topics using nested expressions are as follows:

  • You can use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.
  • If a query does not contain a nested expression, it is evaluated from left to right. For example, "Instrument NOT system OR calibration" finds topics containing the term "instrument" without the term "system", or topics containing the term "instrument" and not "calibration". (On the other hand, "instrument NOT (system OR calibration)" finds topics containing the term "instrument" without either of the terms "system" or "calibration".)
  • Nesting allows you to create more complex search expressions. For example, "instrument AND ((system OR calibration) NEAR performance)" finds topics containing the term "instrument" along with the terms "system" and "performance" close together, or containing "instrument" along with the terms "calibration" and "performance" close together.
  • You cannot nest expressions more than five levels deep.


FAQs

Q. What is Coherent Sampling

A. Coherent Sampling refers to the relationship between the input frequency, sampling frequency, number of cycles in the sampled set and the number of samples. With coherent sampling one is assured that the signal power in an FFT is contained within one FFT bin (assuming a single input tone).

The condition for coherent sampling is given by:

For example if we have Msamples = 211, and fs = 100e6, and we expect and input frequency close to fs/2, let's say fin = 44 MHz,

Then Ncycles = 901.12 which is close to an integer. We could therefore round down to Ncycles = 901 and we would get fin = 43.994140625 Mhz, which is an input frequency that satisfies coherent sampling.

The integer number should be chosen carefully. We have three possible types of integers, even, odd, and prime. Even is not a good idea since we would hit the same code every Msamples, where M can be much less than N. Odd is a better idea since it takes longer to hit the same code. According to some sources a prime number of cycles is the best (with the exception of the prime 2) because it takes a long time before the same code repeats.


Related Documentation

Documentation Access Map

All documentation relating to your Agilent Technologies digitizer may be found either from the CDROM supplied with your product, or from the Agilent website as shown in the diagram below:

Documentation

If you have run the Agilent MD1 software installer for your product on your PC, the related product documentation will have been installed to your hard drive. Otherwise these documents are available for download from the Agilent Technologies website

Document

Startup Guide

Includes procedures to help you to unpack, inspect, install (software and hardware), perform instrument connections, verify operation, and troubleshoot your product. Also includes an annotated block diagram.
User Manual

Provides in-depth information and reference material specific to your digitizer product
Data Sheet

In addition to a detailed product introduction, the data sheet supplies full product specifications.
Soft Front Panel (help system)

Provides information on the use of the Soft Front Panel for MD1 digitizers.
LabVIEW Driver reference (help system)

Provides detailed documentation of the LabVIEW G driver API functions.
IVI Driver reference (help system)

Provides detailed documentation of the IVI-COM and IVI-C driver API functions, as well as information to help you get started with using the IVI drivers in your application development environment.


Full Product Family Listing & Cross-reference tables

This help file has been organized to allow easy access by arranging the product lines under their form factors listed below:

PXI Express High-Speed Digitizers

This product line is composed of Agilent PXI Express new generation of high-speed digitizers.

These are PXI Express compliant, using either a PXIe or PXIe Hybrid slot. Designed to benefit from fast data interfaces, the products can be integrated with other test and automation modules in PXIe and Hybrid chassis slots. The PXI format offers high performance in a small, rugged package. It is an ideal deployment platform for many automated test systems

Agilent Model Number | Model Name
M9202A | PXI Express 12-bit Wideband IF Digitizer
U5203A | PXI Express 12-bit High-Speed Digitizer
PXI Hybrid High-Speed Digitizers

This product line is composed of Agilent PXI Hybrid high-speed digitizers.

These are PXI compliant digitizers, using either a cPCI (J/J2), PXI-1 or PXIe Hybrid slot. The PXI format offers high performance in a small, rugged package. It is an ideal deployment platform for many automated test systems.

Agilent Model Number | Model Name
M9210A | 10-bit Digitizing Scope
M9211A | 10-bit UWB IF Digitizer
AXIe Digitizers

This product line is composed of Agilent Technologies new generation of AXIe Digitizers.

The AXIe format offers high performance in a highly scalable package, offering at least twice the channel density of currently available comparable solutions. Making it ideally suited to large scale experiments in applied physics, such as particle physics, nuclear fusion, hydrodynamics or microwave radio astronomy.

Agilent Model Number | Model Name
M9703A | AXIe 12-bit Wideband Digitizer
U10xx - PCI / PCI Express / CompactPCI / VME Products

Agilent Technologies Inc. acquired Acqiris SA and its product lines in December 2006. Use the tables below to cross reference the Acqiris model name with the newer Agilent model numbers.

8 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
U1061A-001-F50 | DC135
U1061A-001-FHZ | DC135HZ
U1061A-002-F50 | DC140
U1061A-002-FHZ | DC140HZ
U1063A-001 | DC265
U1063A-002 | DC270
U1064A-001-F50 | DC211
U1064A-001-FHZ | DC211A
U1064A-002-F50 | DC241
U1064A-002-FHZ | DC241A
U1064A-004-F50 | DC271
U1064A-004-FHZ | DC271A
U1067A-001 | DP105
U1067A-002 | DP110
U1068A-001 | DP210
U1068A-002 | DP211
U1069A-001 | DP214
U1069A-002 | DP235
U1069A-003 | DP240
U1071A-001 | DP1400
U1071A-001-F50 | DP1400
U1071A-001-FHZ | U1071AHZ1
U1071A-002-F50 | U1071A002
U1071A-002-FHZ | U1071AHZ2
U1071A-004-F50 | U1071A004
U1071A-004-FHZ | U1071AHZ4
U1084A | -
U1091AC10 | DC110
U1091AD06/07 | DP106
U1091A-003 | DP212
10 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
U1062A-001 | DC122
U1062A-002-2F5 | DC152
U1062A-002-2FZ | DC152HZ
U1065A-001-FHF | DC222HF
U1065A-001-F50 | DC222
U1065A-002-F50 | DC252
U1065A-002-FHF | DC252HF
U1065A-004-F50 | DC282
U1065A-004-FHZ | DC282HZ
12 bit Digitizer Products
Agilent Model Number | Acqiris Model Name
n/a | DC436
U1066A-002 | DC438
U1066A-001 | DC440
U1070A-003 | DP306
U1070A-002 | DP308
U1070A-001 | DP310
Analyzers and Averagers
Agilent Model Number | Acqiris Model Name
U1080A-001 | AC240
U1080A-002 | SC240
U1081A-001 | AP100
U1081A-002 | AP101
U1081A-003 | AP200
U1081A-004 | AP201
U1082A-001 | AP240
U1082A-002 | AP235
U1091AAC1 | AC210
U1091ASC1 | SC210


Agilent M9210A Description & Front Panel Connections

The M9210A is a one-slot 3U PXI-Hybrid high-speed Digitizing Scope featuring 2 channels with 1.4 GHz analog bandwidth and up to 4 GS/s real-time sampling rate, significantly reducing data acquisition and testing times. The M9210A Digitizing Scope comes with on-board memory of up to 512 MB. Ideal for high-speed applications such as telecommunications, ATE, and semiconductor testing, the M9210A is the best successor to the Agilent VXI E1428.

The M9210A and M9211A models allow multi-module synchronization thanks to the auto-synchronous bus system able to reach picoseconds-level accuracy between multiple channels.

Most of the technical specifications concerning your particular digitizer are covered in this manual, however for the complete specifications please refer to the product’s datasheet from the Agilent Technologies web site www.agilent.com/find/digitizers. These data sheets are available in pdf format and are best viewed using Adobe Acrobat software. If you have trouble accessing our web site, or viewing the data sheets, please contact your nearest sales office.

Front Panel Connections

M9202A | M9210A | M9211A
Identifier | Puupose | M9202A | M9210A | M9211A
INPUT (1,2) | Analog signal input(s) | SMA female | BNC female | SMA female
TRG (1,2,3) or TRIGGER IN | External trigger input | MMCX female | BNC female | SMA female
CLK 1 IN or CLK IN | External clock input | SMA female | MMCX female | MMCX female
TRG OUT | Trigger signal output | MMCX female
REF IN | Clock reference input (100 MHz) | MMCX female | n/a | n/a
I/O A, B | Provides a programmable I/O digital control line or a 10 MHz clock reference signal. | n/a | MMCX female
AS BUS 2 | Please see Operation of ASBus 2 | n/a | - | -

STATUS LED

LED State | Description
 | Power is not present or the module has a fault.
 | Indicates that the trigger is armed and waiting for a valid trigger to occur.
 | Indicates that a trigger has occurred, and the acquisition is complete.
 | The power-on state immediately after power is applied. Also identifies the module associated with the current channel in the Soft Front Panel when the 'Identify' function is used.


Channel Input Specifications

This section provides information and specifications regarding the input characteristics of the digitizer.

Channel Input

The M9210A has the following front end capabilities:

Model | Impedance & Coupling | Bandwidth guaranteed (typical) | Risetime | BW Limiter selections | FS Collapsed Full Scale:- The maximum value of the ADC input. Voltage ranges | Maximum Offset | Maximum Signal
M9210A | 50 Ω AC/DC | 1.4 GHz (1.5 GHz) | 0.23 ns | 20, 200, 700 MHz | 0.05 - 5.0 V | ±5 V | ±5 V
 | 1 MΩ AC/DC | (300 MHz) | 1.2 ns | 20, 200 MHzFor M9210 with FS > 5 V, only the 20 MHz Bandwidth Limiter is available. 1 | 0.05 - 50 V | ±20 V (@>0.5 V FS) ±200 V (@>5 V FS) | ±300 V

Impedance & Coupling

Coupling

Both AC and DC coupling modes are available. The AC mode couples signals capacitively thus removing the input signal’s DC component and filtering out any signal component below 16 Hz for the 1 MΩ case. DC mode allows all signal components to be passed through to the digitizer.

Impedance

The input channels offer termination in either 50 Ω or 1 MΩ. The M9210A 50 Ω coupling mode offers high quality termination with better than ± 1% precision. 1 MΩ coupling mode provides a high impedance (low load) capability that is suited for use with most standard high impedance probes. The high impedance mode also features low (14 pF typical) capacitance that helps to minimize loading effects that can occur when probing high frequency circuits.

Input Protection

The input amplifiers are protected against over-voltage signals as shown in the table. The 1 MΩ limit refers to the input signal’s DC + peak AC < 10 KHz voltage.

Mezzanine Front-end

The front-end electronics are all mounted on a removable mezzanine card. In the event of accidental damage or as components fatigue over time (e.g. relays in high duty cycle automated testing applications), the mezzanine card allows for fast and efficient replacement.

Bandwidth and Rise Time

The bandwidth specification indicates the frequency at which an input signal will be attenuated by 3 dB (approximately 30% loss of amplitude). The bandwidth also affects the minimum rise and fall times that can be passed through the front-end electronics. A pulse with a very sharp edge will be observed to have a minimum rise time (τmin) determined by the front-end electronics. In general a pulse with a given 10-90% rise time (τ10-90real) will be observed with a slower value given by:

For the M9210A in 1 MΩ coupling the 700 MHz Bandwidth Limiter cannot be used. Furthermore, for FS Collapsed Full Scale:- The maximum value of the ADC input. gain > 5V the 200 MHz Bandwidth Limiter is always active.

M9210A Input Voltage and Offset

The input channel provides a fully programmable amplifier with variable input voltage and offset. Full Scale (FS Collapsed Full Scale:- The maximum value of the ADC input.) input voltages are selectable in a 1, 2, 5 sequence for the range shown above. Care should be taken to select an input voltage range that will allow the signal to be recorded using as much dynamic range of the digitizer as possible. The Variable Offset is programmable in the range of ±2 V when using an FS Collapsed Full Scale:- The maximum value of the ADC input. Input Voltage setting of 500 mV or below, increasing to ± Maximum Offset for FS Collapsed Full Scale:- The maximum value of the ADC input. settings above 500 mV (see the preceding table). The raw 10-bit ADC Collapsed Analog to Digital Converter data values are read as 16-bit integers in the range [-32768, +32704] with nominal steps of 64 LSB Collapsed Least Significant Bit:- The bit that represents the smallest fraction of a value.’s between successive codes and the first and last values reserved for underflow and overflow respectively. The actual values returned use 12 bits and unequal spacing to correct for the measured DC integral non-linearity of each ADC Collapsed Analog to Digital Converter involved. The midpoint value, 0, of the range corresponds to the negative of the offset voltage. Thus the Full Scale Range (FSR Collapsed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages.) goes from:

-Offset Voltage - (FS Collapsed Full Scale:- The maximum value of the ADC input./2) to -Offset Voltage + (FS Collapsed Full Scale:- The maximum value of the ADC input./2)

Signals going outside of the FSR Collapsed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages. will be clipped and data values for the clipped portion of a signal should be regarded as erroneous.

Vertical Resolution

The digitizers described in this manual use an ADC Collapsed Analog to Digital Converter system with 10 bits of vertical resolution (1024 levels). The dynamic range of the ADC Collapsed Analog to Digital Converter covers the Full Scale Range (FSR Collapsed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages.) of the Input Voltage setting. For example, if the Input Voltage is set to 1 V then the ADC Collapsed Analog to Digital Converter resolution is equivalent to 0.977 mV. To obtain the best dynamic range from the ADC Collapsed Analog to Digital Converter care should be taken to ensure that the input signal varies over more than 50% of the Input Voltage FSR Collapsed Full Scale Range:- The span of the voltage input of the Digitizer (negative to positive) including the configured offset voltages. setting.

Accuracy and Linearity

This digitizer uses low noise front-end electronics in order to ensure that voltage measurement is made with accuracy and precision.

DC voltage accuracy, at 0 V offset, is better than ±2% (±1% typical) of the input voltage full scale. The static differential nonlinearity is < 2 LSB Collapsed Least Significant Bit:- The bit that represents the smallest fraction of a value.. The integral linearity is good to ± 1 LSB Collapsed Least Significant Bit:- The bit that represents the smallest fraction of a value. (typical).

Using Probes

The 50 Ω and 1 MΩ input impedance settings make it possible to use M9210A digitizers with a wide variety of probes. The 50 Ω setting is most commonly used for active probes and low impedance (500 Ω) passive probes. The 1 MΩ setting is normally used for high impedance probes. Before using any Passive Probe with a digitizer care should be taken to check that the probe has been correctly adjusted (refer to the Probe’s Calibration procedure).

Passive high impedance probes are not suitable for high fidelity measurements above 100 MHz. The non-negligible (5-10 pF) tip capacitance loads the signal causing distortion and/or ringing when combined with the ground lead inductance.


Data Acquisition

The table below summarizes the data acquisition characteristics, and further discussed in the sections that follow:

Model | Max. Sampling Rate | Max Converters per Channel / Channels | Default Memory Samples/ channel | Maximum Optional Memory Samples/ channel | Maximum Segments
M9210A | 4 GS/s | 2 / 2 | 256K | 256M | 125K

Sampling Rate

The 10-bit digitizers contain an analog-to-digital conversion (ADC Collapsed Analog to Digital Converter) system that can sample waveforms, in a real time sampling mode, at rates from the maximum allowed rate down to 100 S/s (10 ms per point). The sampling rate can be programmed and is selectable in a 1, 2, 2.5, 5 sequence (i.e. 1 MS/s, 2 MS/s, 2.5 MS/s, 5 MS/s, 10 MS/s, … 1 GS/s, 2GS/s, 4 GS/s, 8 GS/s). The maximum sampling rate shown above exploits the possibility of combining channels.

Acquisition Memory

Data from the ADC Collapsed Analog to Digital Converter is stored in on-board acquisition memory. The amount of memory in use for acquisition can be programmed and is selectable from 1 point to the full amount of acquisition memory available.

For technical reasons, a certain acquisition memory “overhead” is required for each waveform, reducing the available memory by a small amount. In order to simplify programming, an interface function recommends the best sampling rate and the maximum possible number of data points, taking into account the available memory, the requested time window, the number of segments (in Sequence mode), as well as the required memory overhead.

To ensure maximum sampling rate and high timing resolution, we strongly recommend the use of long acquisition memories whenever possible.

Single and Sequence Acquisition Modes

Digitizers acquire waveforms in association with triggers. Each waveform is made of a series of measured voltage values (sample points) that are made by the ADC Collapsed Analog to Digital Converter at a uniform clock rate. The digitizer can also measure and store the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI Collapsed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time).).

To maximize sampling rates and utilize memory as efficiently as possible, the digitizers include both Single and Sequential storage modes. For both of these modes the data of all of the active channels is acquired synchronously; all of the ADC Collapsed Analog to Digital Converter’s are acquiring data at the same time, to within a small fraction of the maximum sampling rate.

The Single Acquisition mode is the normal operation of most digitizer products. In this mode an acquisition consists of a waveform recorded with a single trigger. The user selects the sampling rate and acquisition memory size and sets the number of segments to 1 (default value).

The digitizers also feature a Sequence Acquisition mode. In the API, the term 'MultiRecord' is used for 'Sequence' and 'Record; is used for 'Segment'. This allows the capture and storage of consecutive “single” waveforms. Sequence Acquisition mode is useful as it can optimize the digitizer’s sampling rate and memory requirements for applications where only portions of the signal being analyzed are important. The mode is extremely useful in almost all impulse-response type applications (RADAR, SONAR, LIDAR, Time-of-Flight, Ultrasonics, Medical and Biomedical Research, etc.).

In Sequence Acquisition mode the acquisition memory is divided into a pre-selected number of segments. Waveforms are stored in successive memory segments as they arrive. Each waveform requires its own individual trigger. The memory can be divided into any number of segments between 2 and 1000 (up to 16000 segments with the M64M option and 125000 segments with options M256M or greater). In Sequence Acquisition mode the user needs to specify the sampling rate, the total acquisition memory, and the number of segments. Note that the Single Acquisition mode is just a special case of the Sequence Acquisition mode with the number of segments set to 1.

Sequence acquisition enables successive events, which can occur within a very short time, to be captured and stored without loss. A crucial feature of Sequence Acquisition mode is that it has a very fast trigger rearm time. A fast trigger rearm helps produce very low “dead time” (< 350 ns for the highest available sampling rates using internal memory and < 1.8 μs for the highest available sampling rates with optional memory) between the segments of a sequence acquisition. The “dead time” is the period after the end of an event when the card cannot digitize data for a new trigger event.

Trigger Time Interpolator

The digitizer also measures and stores the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI Collapsed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time).). This information is essential for determining the precise relation between the trigger and the digitized samples of the signal. The TTI Collapsed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time). resolution determines the resolution of the trigger time stamps. Please refer to the M9210A datasheet for the relevant specifications.

Timebase Range

The timebase range defines the time period over which data is being acquired. For example, the has a standard acquisition memory of 256 Kpoints and maximum sampling rate of 2 GS/s. Therefore, at the maximum sampling rate, the digitizer can record a signal over a timebase range of up to 130 µs (approx. 260,000 points * 0.5 ns/point). The timebase range can be adjusted by varying the amount of acquisition memory or the sampling rate of the digitizer.

Combining channels

The M9210A digitizer offers the possibility of combining the converters (and their memories) from two M9210A channels to analyze a single input channel. With this feature the maximum sampling rate and the maximum amount of acquisition memory can be doubled if all of the input channels are not of immediate interest.


Trigger

Normally the trigger settings applied to the digitizer are used to determine the time at which the device will stop acquiring data. The M921xA models are also capable of a ‘Start on Trigger’ mode of acquisition. The various trigger settings are outlined below.

Trigger Source

The digitizers provide a front panel external Trigger IN inputs that provides a fully functional trigger circuit with selectable coupling, level and slope as for the Internal Triggering source. The external trigger has a fixed 50 Ω termination impedance. It also allows optional BW limiter selections of 20, 200, or 700 MHz.

The external trigger circuit has diode protection against overload. A ±5 V limit on trigger signals should be respected, although somewhat higher voltages for short time periods will not damage the unit.

Trigger Impedance & Coupling

The M9210A trigger has a 50 Ω termination. The trigger frequency range is DC to 1 GHz, 0.5/1/2/5 V full-scale (FS Collapsed Full Scale:- The maximum value of the ADC input.) and threshold adjust range ± FS Collapsed Full Scale:- The maximum value of the ADC input./2.

Trigger coupling is used to select the coupling mode applied to the input of the trigger circuitry. Modes available include AC LF Reject and DC. The AC LF Reject mode couples signals capacitively and removes the input signal's DC component and signals below 50 Hz. DC mode allows all signal components to be passed through to the trigger circuit. The HF Reject mode removes signal components above 50 KHz.

Trigger Level

The trigger level specifies the voltage at which the selected trigger source will produce a valid trigger. All trigger circuits have sensitivity levels that must be exceeded in order for reliable triggering to occur.

Edge Trigger Slope

The trigger slope defines which one of the two possible transitions will be used to initiate the trigger when it passes through the specified trigger level. Positive slope indicates that the signal is transitioning from a lower voltage to a higher voltage. Negative slope indicates the signal is transitioning from a higher voltage to a lower voltage.

Trigger Time Interpolator

The digitizer also measures and stores the arrival time of each trigger using the information from the on board Trigger Time Interpolator (TTI Collapsed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time).). This information is essential for determining the precise relation between the trigger and the digitized samples of the signal. The TTI Collapsed Trigger Time Interpolator:- A function that accurately measures the time from the trigger point to the first sample point. The TTI permits accurate positioning of the trigger signal with respect to the internal clock (sampling time). resolution determines the resolution of the trigger time stamps. Please refer to the M9210A datasheet for the relevant specifications.

HF Trigger

The digitizers implement an HF trigger that allows triggers to be reliably accepted at rates above ~ 1 GHz. In this mode, triggers occur on every fourth positive edge. The window trigger mode is not available.

Spike Stretcher

The M921xA model’s trigger circuit also has a Spike Stretcher mode which ensures that even very short pulses are capable of generating triggers. This mode is useful if the time interval during which the trigger signal satisfies the threshold condition is less than 0.5 ns and the trigger frequency is less than 10 MHz. The trigger slope is positive in this mode.

Multi-source Trigger

The M9210A model permits triggers that require a pattern condition including combinations of the trigger channels and the external trigger. The trigger condition defined above, on each of the inputs, defines the TRUE/FALSE state of each input. These states can be logically combined with AND, OR, NAND, or NOR to define the overall trigger condition. Potential triggers can then occur on the FALSE to TRUE transitions of the combined signal.

There is a small (~ns) delay between the times at which two simultaneous inputs arrive at the logical element that defines the overall trigger condition. If necessary, this must be corrected for by cable delay on the external input; the delay will depend on the overall configuration and therefore must be determined by the user.

Pre- and Post-Trigger Delay

To increase trigger flexibility a pre- or post-trigger delay can be applied to the trigger position.

The amount of pre-trigger delay can be adjusted between 0 and 100% of the acquisition time window (i.e. sampling interval x number of samples), whereas the post-trigger delay can be adjusted within the time interval corresponding to [0, 231 – 1 samples].

Pre- or post-trigger delays are just different aspects of the same trigger positioning parameter:

  • The condition of 100% pre-trigger indicates that all data points are acquired prior to the trigger, i.e. the trigger point is at the end of the acquired waveform.
  • The condition of 0% pre-trigger (which is identical to a post-trigger of 0) indicates that all data points are acquired immediately after the trigger, i.e. the trigger point is at the beginning of the acquired waveform.
  • The condition of a non-zero post-trigger delay indicates that the data points are acquired after the trigger occurs, at a time that corresponds to the post-trigger delay, i.e. the trigger point is before the acquired waveform.

The digitizer hardware accepts pre- and post-trigger adjustments in increments of 16 samples. By definition post-trigger settings are a positive number and pre-trigger settings are a negative number.

Thus it is only natural that the software drivers treat pre- and post-trigger delays as a single parameter in seconds that can vary between –nbrSamples * samplingInterval (100% pre-trigger) and +maxPostTrigSamples * samplingInterval (max post-trigger).

Since the Agilent software drivers provide very accurate trigger position information upon waveform readout, the accepted resolution of the user-requested pre-/post-trigger delay is much better than 16 samples. For more details, refer to Programmers Guide - Trigger Delay and Horizontal Waveform Position.

Trigger Status

The front panel includes a tri-color LED indicator to show the status of the trigger.

The user can override the default functions and program the LED color in an application-specific manner.


External Clock and Reference

For applications where the user wants to replace the internal clock of the digitizer and drive the ADC Collapsed Analog to Digital Converter with an external source, either an External Clock or an External Reference signal can be used. The Clock or Reference signals can be entered into the digitizer by the dedicated REF IN and CLK IN connectors.

External Clock (CLK IN)

The External Clock may be used, it must be continuously present if selected for the digitizer to operate correctly. The input is 50 Ω, AC coupled.

Parameter | Value
Frequency | 200 MHz - 2 GHz
Minimum Amplitude | 0.5 Vpk-pk into 50 Ω
Maximum Signal Power | +7 dBm (1.4 V pk-pk into 50 Ω)
Maximum Amplitude | ±5 V
Threshold | -3.0 V to 3.0 V

External Reference (REF IN)

For applications that require greater timing precision and long-term stability than is obtainable from the internal clock, a 10 MHz Reference signal can be used. The External Reference is nominally at 10 MHz. However, frequencies in a range will be accepted.

If your input is not at exactly the specified value, you must remember to compensate for the difference in your application since the digitizer and the driver have no way to know about such deviations.

This input is AC-coupled and 50 Ω terminated.

Parameter | Value | Tolerance
Nominal Frequency | 10 MHz | ±10 KHz
Minimum Amplitude | 0.5 Vpk-pk into 50 Ω |
Maximum Voltage | ±10 Vdc |

If synchronization between several digitizers is required, the reference signal should be applied to all of them.


Internal Calibration

The digitizer includes a high precision voltage source and a 16-bit DAC, used to perform the input voltage and offset calibration.

The software drivers supplied include calibration functions for the timing, gain and offset parameters, which can be executed upon user request. The digitizers are never calibrated in an “automatic” way, (i.e. as a side effect of another operation). This ensures programmers have full control of all calibration operations performed through software in order to maintain proper event synchronization within automated test applications.

For accurate time and voltage measurements it is recommended to perform a calibration once the module has attained a stable operating temperature (usually reached with a few minutes of digitizer operation after power on). And subsequently a self-calibration should be carried out after any configuration changes are made to the digitizer, before making acquisitions.

A full internal calibration of a digitizer can be time consuming. Therefore, several other options are available. They are documented in the calibration routines associated with the API. A program can always be started with the digitizer in an un-calibrated state and data taken can be used for many kinds of testing. However, as soon as good data respecting the specifications of the instrument is required a calibration of at least the current acquisition state is needed. The full internal calibration has the advantage that it generates the calibration constants needed for any possible configuration of the instrument; its disadvantage is the time taken. If a more selective calibration is done it will allow the generation of good data in the current acquisition state. This calibration will remain useable whenever that acquisition state is used again for as long as the temperature of the instrument does not change significantly. A fast calibration of a channel in a configuration can be done in around a 5 seconds. Many applications can save time by only performing calibration for the configurations that will actually be used.

Calibration can usually be performed with signals present at the channel, external, and clock inputs. However, to ensure the best performance, or if the calibration is found to be unreliable, as shown by a calibration failure status, it will be necessary to remove such signals.

An application program will close devices if it exits normally. When a digitizer is closed in this way its power consumption will be reduced. This has the consequence that if another application program is started later an appropriate warm-up period may have to be respected before a calibration is called for and full performance expected.

Factory Calibration

Whilst the Internal Calibration function will provide a good degree of confidence that your instrument is operating within its specifications on a day-to-day basis, Agilent recommends that each instrument undergoes a Factory Calibration at least annually to ensure that it remains within the specified performances.

Factory Calibration is the process of measuring the actual performance of an instrument-under-test using lab instruments that in turn have significantly better performance than the instrument-under-test. Lab instrument performance must be traceable to the International System (SI) Units via a national metrology institute (NIST, NPL, NRC, PTB, CENAM, INMETRO, BIPM, etc.)

The measured performance is then compared to published data sheet specifications. Agilent Technologies tests the performance corresponding to all data sheet specifications, for all installed options, every time. If we observe your instrument to be out-of-specification, we always adjust it and re-test before we return it to you.

For more information, or to return your instrument to Agilent for calibration please see www.agilent.com/find/calibration


External Trigger Output

You are here: M9210A User Manual > Trigger Output

Trigger Output

When the digitizer is ready to be triggered and a valid trigger signal occurs, a trigger output is generated for external use. This signal is available on the front panel TRG OUT MMCXTRG OUT MCX connector, and may be enabled or disabled as required. The pulse ends when the data acquisition for the trigger in question is complete.

There are several trigger sources which may be assigned to the Trigger Out connector, but the available options will depend on the model being used.

Trigger Out Sources | Description of signal
(0) No Sync | The input trigger signal is sent directly to the Trigger Out.
(1) Sync | A trigger signal resynchronized to the sample clock is sent to the Trigger Out.
(3) Trig compare | The trigger input condition has been satisfied, but not necessarily triggered e.g the trigger enable was not asserted.
(17) High Level | Fixed 'high' level signal for debug purposes.
(18) Low Level | Fixed 'low' level signal for debug purposes.

Figure 1 - Trigger Output Block diagram:

In the default software configuration, the output swing is 1.6 V (±0.8 V) when unloaded and 0.8 V (±0.4 V) when terminated on 50 Ω. The rise and fall times are 2.5 ns typical. The offset can be adjusted, by software control in the range [–2.5 V to +2.5 V] unloaded, or [-1.25 V to +1.25 V] into 50 Ω. The maximum output current capability is ±15 mA. As the output is retro-terminated, it is possible to drive a 50 Ω line un-terminated (HiZ) without loss of performance.

For a TTL compatible signal, set the offset to 1.0 V and the swing at destination will be +0.2 to +1.8 V.

For an ECL compatible signal, terminated on 50 Ω to –1.2 V, set the offset to –1.2 V and the output will be in the range [–0.8 to –1.6 V]).

Alternatively, to reduce the current drawn from the digitizer, the terminations shown here can be used:

Figure 2 - Suggested trigger signal terminations

For the certain U1061A, U1062A, U1065A, U1064A, M9202A, M9210A, M9211A, U5203A. 1 modules, a standardized trigger out signal can also be routed to the PXI Bus Star Trigger line.

For the PXI Express, PXI Hybrid, 10-bit Family and U1071A Family, the offset control range is reduced slightly. It is [-2.3 to +2.3 V] unloaded, or [-1.15 to +1.15 V] into 50 Ω.

The External Trigger Output functionality is implemented in the hardware. No Trigger Out signal occurs for software-generated triggers such as those of the AUTO mode of the SFP.


Special Inputs & Controls

You are here: M9210A User Manual > Multi-Purpose Inputs and Outputs

Multi-Purpose Inputs and Outputs (I/O A, B, C)

The I/O A, I/O B or I/O C may be used for any of the functions shown in the following table:

IO Connector Functions | Type | Description of signal | Notes
Inputs
Disabled | - | IO connector is disabled. |
In: Enable Trigger (AND) | Level | If one of the I/O is set to this value then the input must be high before an edge can be accepted. If multiple inputs are set to this value a logical AND is used. |
Outputs |  |  |
Out: 10 MHz Reference Clock | Clock | To ensure good rise time characteristics the output impedance is 50 Ω.This signal can be used as an input to 1 (or 2 using a T split) CLK IN connectors. Note: This signal is the internal 10 MHz and is not available if the External Reference Clock is in use. | On U1084A the signal is only available on IO A.
Out: Skipping to next Seg | Pulse | Indicates that the acquisition has skipped to the next segment. This will occur in certain models which support the 'skip' command (see the Programmers Guide) or in normal digitizer operation at the end of each segment. | Not available on U1084A Averager & PeakTDC models or U1082A Signal Analyzers.
Out: Acquisition Active | Level | Indicates that the acquisition is currently running. |
Out: Trigger Armed | Level | Active when the instrument is armed and waiting for a valid trigger event. |

To ensure proper operation of the segment recording of hardware markers, the logical state of I/O A, I/O B, and I/O C inputs must be stable for a time interval starting 30 ns before the trigger and continuing until 30 ns after it. This implies that the HF Reject trigger coupling should not be used. If the individual inputs are not in the disable state the corresponding bits will be useless.

Signal Logic Levels

The multi-purpose IO signals are 3.3 V CMOS compatible. The levels shown in the table below should be observed.

Direction | Low level | High level
Input | <0.8 V | >2.0 to 3.45 V
Output | In the range 0 to 0.8 V | In the range 1.6 to 3.3 V
As an Input

The input is high-impedance and will be pulled high if unconnected via an internal weak pull-up.

As an Output

The high level output will typically give 0.8 V into 50 Ω. As can be seen in the diagram below, the 3.3 V output buffer has a 50 Ω resistor in series. Therefore the available output high level voltage will depend on the load applied. In the example below a 50 Ω termination will result in a nominal high level of 1.6 V. (Vo = Rload/50 + Rload * 3.3)

Figure 3 - Output equivalent circuit


Electrical & Environmental Specifications

For full specifications, please refer to the product data sheet which may be found on the CD which came with your product, or from the Agilent Technologies website: www.agilent.com/find/M9210A


Operation of ASBus 2

The digitizers may be used in applications that require many data acquisition channels. In such cases it is possible to use more than one digitizer in a standard CompactPCI/PXI crate. Each DC Series 10-bit digitizer includes AS bus 2, a proprietary high bandwidth auto-synchronous bus system that allows multiple digitizers to work together synchronously.

AS bus 2 distributes both the clock and trigger signals along a plug-in front panel bus, between all the digitizers that participate in the system. It allows any digitizer to act as the trigger source and any other digitizer to act as the clock source (acquisition master), enabling all the digitizers to be clocked at the same time. Synchronizing the clock signals between the devices improves the accuracy of cross-channel measurements and is essential for accurate time correlation between signals on different channels.

AS bus 2 is intended to connect modules of the same type, i.e. of the same model number, although some exceptions to this rule might be possible. If modules with the same model number, but different memory length options, are connected only the shortest memory length can be used.

The AS bus 2 connector is located on the front panel of each module. Bridges are used to connect adjacent modules for synchronization. An AS bus 2 multi-instrument is activated through software by a function call. Up to 5 6U modules, or 3 3U modules, may be synchronized with the AS bus 2. Consequently no more than 4 adjacent AS bus 2 bridges should be installed. More detailed information and the commands required to set up the AS bus 2 clock and trigger distribution can be found in the Programmers Guide (U1092-90003).


Utilities

This section describes supplied programs which may be used to configure various aspects of your instruments:

EEPROM Programming Utility (AcqEEPROMProg)


SFP Command Line Switches

You are here: M9210A User Manual > Utilities > EEPROM Programming Utility (AcqEEPROMProg)

Agilent Acqiris EEPROM / CPLD-FPGA Programming Utility

The EEPROM programming utility (AcqEepromProg.exe) is used to load either instrument options or firmware to your Agilent instrument.

Syntax:
AcqEepromProg.exe [-eeprom | -maincpld] [sn:<serial>] [efw:<eepromNumber>] [<filename>]

All of the listed switches are optional, please see the notes below for details.

Filename conventions

Files with the ".epr" extension contain instrument options and are generated by Agilent for a specific instrument serial number, they may not be used on instruments with other serial numbers. These files must be loaded to the device Option EEPROM.

Files with the ".vme" or ".svf" extension contain instrument operating firmware generated by Agilent, but may be used on any instrument of the appropriate model type. These files must be loaded into the instrument Firmware EEPROM or CPLD

If one or mores spaces appear in the filename or path, the double quotes are required on the filename string as shown in the examples below.

It is not possible for the utility to check that the file is suitable for the FPGA Collapsed Field Programmable Gate Array / CPLD of the specified device, so please use this mode carefully. Programming a device with the incorrect firmware file may render it unusable.
However, as long as the device has not yet been re-booted (power cycled) it will be possible to re-write the correct file. Conversely, if the device has been incorrectly programmed and subsequently re-booted, it will be necessary to return it to an Agilent Service Center for recovery.

Available Switches
Switch | Function
-eeprom | Specifies that the firmware file should be loaded into the device Option EEPROM
-maincpld | Specifies that the firmware should be loaded into the main Firmware EEPROM / CPLD of the instrument
efw:<eepromNumber> | Specifies the Firmware EEPROM number for the firmware to be loaded into. Valid values are '0' or '1'. The value '1' is only supported by the U1084A instrument, and only valid when preceded by -maincpld
sn:<SerialNumber> | Specifies the module to program based on it's serial number. Useful where multiple modules are connected to the host.
Usage examples:
AcqEepromProg.exe

Opens a file dialog box, then loads the content of the chosen file into the EEPROM/CPLD-FPGA Collapsed Field Programmable Gate Array of a defined device. If the chosen file has a ".epr" extension, the application will load the file into the Options EEPROM of the device that matches the serial number in the file.

If the chosen file has a ".vme" or ".svf" extension, the application will prompt the user for a target device when there are several devices connected. If there is only one device, that device will be chosen without prompting.

AcqEepromProg.exe <filename>

example:

AcqEepromProg.exe DC271_CH12345.epr

Loads the content of the file 'DC271_CH12345.epr' into the Options EEPROM of the specified device. If there is only one device, that device will be chosen without prompting. When several devices are connected, the application will prompt the user for a target device.

AcqEepromProg.exe -eeprom <filename>

example:

AcqEepromProg.exe -eeprom U1084A_CH12345.epr

Loads the content of the file 'filename' into the Options EEPROM of the specified device. The serial number in the file is used to find the proper target device. The serial number encoded in the options file must match the serial number of the target device.

AcqEepromProg.exe -maincpld <filename>

example:

AcqEepromProg.exe -maincpld "C:\Program Files\IVI Foundation\IVI\Drivers\AgMD1\Firmware\U1084_dig_02380181.vme"

Loads the content of the file 'filename' into the main Firmware EEPROM / CPLD of the specified device. If there is only one device, that device will be chosen without prompting. When several devices are connected, the application will prompt the user for a target device.

AcqEepromProg.exe -maincpld sn:<serial> <filename>

example:

AcqEepromProg.exe -maincpld sn:12345 "C:\Program Files\IVI Foundation\IVI\Drivers\AgMD1\Firmware\m9202_ddc_020000381.vme"

Loads the content of the file 'filename' into the main Firmware EEPROM / CPLD of the specified device.

AcqEepromProg.exe -maincpld dev:<number> -efw:<eepromNumber> <filename>

example:

AcqEepromProg.exe -maincpld dev:1 efw:1 "C:\Program Files\IVI Foundation\IVI\Drivers\AgMD1\Firmware\U1084_dig_02380181.vme"

Loads the content of the file 'filename' into the Firmware EEPROM specified by 'eepromNumber'. The option 'efw' only supports values 0 or 1 and the value 1 is only supported on U1084A instruments.

Requires:
  • QtCore4.dll
  • Qt3Support4.dll
  • QtGui4.dll
  • AgMD1Fundamental.dll
Licensing:

The compiled code used to achieve the 'AcqEepromProg.exe' functionalities are provided in source code from the Lattice 'ispVM(r) Software' package. The use of this compiled source code is subject to conditions, as explained in the section 2.C of the 'Lattice Standard License Agreement.txt' file, which is an integral part of this package.

Copyright (C) 2004, 2005-2012 Agilent Technologies, Inc.


U1092A-HVB XA100 BNC Input Over-voltage Protection

This overvoltage protection kit allows the digitizers with 50 Ohm input (not high-impedance input models) to withstand a high voltage surge of up to 5 kV.

The XA100 overvoltage protection kit contains 2 parts:

  • A 3dB BNC Attenuator
  • A 90 V BNC Spark Gap
Specifications
Parameter | Value
Frequency range | DC to 1 GHz
Input impedance | 50 Ω
Attenuation | 3 dB
VSWR (DC to 1 GHz) | < 1.25
Impulse discharge current (8/20 us pulse) | 10 kA
Weight | 60 g
Length | 85 mm

Both the Spark Gap and the Attenuator MUST be used together in order to fully protect the modules.

In order to limit the input current, the Attenuator MUST be inserted between the Spark Gap and the input of the module.